Forum
Welcome, Guest
Username: Password: Remember me
This is the optional category header for the Suggestion Box.
  • Page:
  • 1

TOPIC:

this vdi was not mapped to destination SR in VM.migrate_send operation 8 months 1 week ago #1952

I am running HA-LIZARD No San with XCP-ng 8.

When I try to move some VM's from one server to the other, I get "this vdi was not mapped to destination SR in VM.migrate_send operation" error message, and I cannot move them.

Once, I was able to find the solution online and fixed the issue, but now I am having hard time finding it.

I wonder what causes this error on VM's and what is proper procedure to fix.

Plus, for some VM's, I get no option to migrate the VM to the other server at all. What would be causing this?

I have attached two attachments for the two issue cases.
Attachments:

Please Log in or Create an account to join the conversation.

this vdi was not mapped to destination SR in VM.migrate_send operation 8 months 1 week ago #1953

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 638
Regarding the VDI error, those are likely due to a cdrom mount that is pointing to an iso image that is no longer available or an SMB storage repository which normally exposes the file is detached. Ejecting the cdrom usually fixes this.

Same is true for network interfaces. If a network is not available on the target or the required network is in the down state on the target migration and even VM start would fail

Regarding VMs that cannot migrate. There are many possible causes. HA lizard does not interfere with any of these operations. This could be due to missing VM tools or pv drivers, but is hard to tell without knowing what the VM operating system is.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1