Forum
Welcome, Guest
Username: Password: Remember me
This is the optional category header for the Suggestion Box.
  • Page:
  • 1

TOPIC: Slave won't Auto-Promote: XCP-ng Version 7.5.0

Slave won't Auto-Promote: XCP-ng Version 7.5.0 1 month 3 weeks ago #1715

XCP-ng Version 7.5.0

Just deployed a test bed for HA-Lizard using XCP-ng 7.5.0. Similar problem to that experienced with 7.6.0

The slave won't auto-promote and fail over.

Pulled the plug on the master to simulate a disaster scenario but HA-Lizard is still waiting for the Master to come back online 20 minutes later. If i power the master back up, it all comes back online normally withing a few minutes.


Master prior to disaster event.
| ha-lizard Version: 2.1.4 |
| Operating Mode: Mode [ 2 ] Managing All VMs in Pool |
| Host Role: master |
| Pool UUID: a208b84f-0992-09e3-16a2-8f395836781b |
| Host UUID: 77af6d41-9110-4210-aa66-aaee43d65760 |
| Master UUID: 77af6d41-9110-4210-aa66-aaee43d65760 |
| Daemon Status: ha-lizard is running [ OK ] |
| Watchdog Status: ha-lizard-watchdog is running [ OK ] |
| HA Enabled: true |
Pool HA Status: ENABLED


SLAVE prior to disaster event.
| ha-lizard Version: 2.1.4 |
| Operating Mode: Mode [ 2 ] Managing All VMs in Pool |
| Host Role: slave |
| Pool UUID: a208b84f-0992-09e3-16a2-8f395836781b |
| Host UUID: 2599780c-d5e1-4747-9452-43da8f550d8d |
| Master UUID: 77af6d41-9110-4210-aa66-aaee43d65760 |
| Daemon Status: ha-lizard is running [ OK ] |
| Watchdog Status: ha-lizard-watchdog is running [ OK ] |
| HA Enabled: true |
Pool HA Status: ENABLED




SLAVE after disaster event.

[root@ks2 src]# ha-cfg status
timeout
| ha-lizard Version: 2.1.4 |
| Operating Mode: Mode [ 2 ] Managing All VMs in Pool |
| Host Role: slave |
| Pool UUID: |
| Host UUID: 2599780c-d5e1-4747-9452-43da8f550d8d |
| Master UUID: 77af6d41-9110-4210-aa66-aaee43d65760 |
| Daemon Status: ha-lizard is running [ OK ] |
| Watchdog Status: ha-lizard-watchdog is running [ OK ] |
| HA Enabled: TIMEOUT |
Pool HA Status: TIMEOUT

Please Log in or Create an account to join the conversation.

Slave won't Auto-Promote: XCP-ng Version 7.5.0 1 month 3 weeks ago #1717

sorry... this is in the wrong section... I can't edit or delete. The forum thinks I'm spamming!

I guess i am now heh :whistle:

Please Log in or Create an account to join the conversation.

  • Page:
  • 1