Forum
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: after failover slave did not switch to master

after failover slave did not switch to master 1 month 2 days ago #1772

Hi,

In my scenario have two servers (xen01as master and xen02 as slave) with local storage and HA enabled. I've had a situation where management went down for xen01 but production and storage replication was up and reachable. This situation took about 20 min and we figure out some strange behavior on msSQL DB. Management has been recovered (firewall issue) but now xen02 is acting as a master for ha and for iscsi replication.
My question is, should I back to my xen01 as master manually? Or this should be done automaticly but I've miss some configuration?

PS. VM's are all the time on xen01
EDIT: I'm using Xenserver 7.5 and HA-Lizard nosan installer 2.1.4

Rregards
Marek

Please Log in or Create an account to join the conversation.

Last edit: by Marek.

after failover slave did not switch to master 3 weeks 2 days ago #1776

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 539
excuse the late reply.

Looks like an HA event triggered and your slave was promoted to the new master. That worked as it should have. After the failover, ha-lizard will not auto switch back to the old master. You can safely keep running in the current state. If you really want to revert to your original master, put the storage into manual mode, exposing the storage on the original master and then use xe tools to switch master. WHen done, exit manual mode for the storage.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1