Forum
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: compatility with xenserver 7.6

compatility with xenserver 7.6 3 months 2 weeks ago #1749

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 549
download this script, make executable and then run. It will install the deps and allow you to get past this.

halizard.org/release/misc/install_nosan_deps

Please Log in or Create an account to join the conversation.

compatility with xenserver 7.6 3 months 2 weeks ago #1750

That seemed to get past the previous issue and I got everything installed on both master and slave. I had left the VMs running on the master while finishing up (since they seemed to be running ok.) But something is wrong with my master now. I'm all kinds of confused here. The master is working and using the ISCI drives (I have 2) but see below.

| iSCSI-HA Version IHA_2.2.0 |
| Fri Dec 7 15:10:00 EST 2018 |

| iSCSI-HA Status: Running 28732 |
| Last Updated: Fri Dec 7 15:09:59 EST 2018 |
| HOST ROLE: MASTER |
| DRBD ROLE: iscsi1=Primary |
| DRBD CONNECTION: iscsi1 in Connected state |
| ISCSI TARGET: Stopped [expected running] |
Control + C to exit


| DRBD Status |

| version: 8.4.5 (api:1/proto:86-101) |
| srcversion: 2A6B2FA4F0703B49CA9C727 |
| 1: cs:Connected ro:Primary/Secondary ds:Diskless/UpToDate C r
|
| ns:0 nr:548 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0 ep:1 wo:f oos:0 |
| 2: cs:Connected ro:Secondary/Secondary ds:Diskless/UpToDate C r
|
| ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0 ep:1 wo:f oos:0 |

Please Log in or Create an account to join the conversation.

compatility with xenserver 7.6 3 months 2 weeks ago #1751

  • Victor Hugo
  • Victor Hugo's Avatar Topic Author
  • Offline
  • Posts: 9
Hi,

When we try to update the ha-lizard-2.2.0-2.rpm, it show this error:

warning: %post(ha-lizard-2.2.0-2.noarch) scriptlet failed, exit status 1

I get a look on the post-script inside of the rpm and run it manually without error.. but, every time that I run the "rpm -Uvh ha-lizard" I get this error.

thanks

Please Log in or Create an account to join the conversation.

compatility with xenserver 7.6 3 months 2 weeks ago #1752

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 549
Can you reproduce the error again and post the output? This time use
rpm -Uvvh ha-lizard-2.2.0-2.rpm --force
which should show us what has gone wrong.

Also, I tested this on 7.5 and cannot reproduce the error..

Please Log in or Create an account to join the conversation.

compatility with xenserver 7.6 3 months 2 weeks ago #1753

  • Victor Hugo
  • Victor Hugo's Avatar Topic Author
  • Offline
  • Posts: 9
Hi,

running it again (on slave) I don't have any issue !!! :-(
Just now, I cant run it on master (it is in production).

Maybe in the next maintenance windows.

PS1: the xenserver version is 7.2.
PS2: anythink work fine anyway.

thanks

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2