Forum
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Different sized storage

Different sized storage 1 year 3 months ago #1356

Right, it was the hostname :) I had it wrong :)

Next issue, I'm unable to access the shared iSCSI target - I get a message stating "Logging in to iSCSI target failed" when I scan for the target host - I am able to ping that IP 10.4.0.3 and when I click scan it takes some time but that's where it ends. Any idea?
The administrator has disabled public write access.

Different sized storage 1 year 3 months ago #1357

It looks like /dev/sda7 is already mounted somewhere
The administrator has disabled public write access.

Different sized storage 1 year 3 months ago #1358

Hi Salvatore, thank you for your feedback!

I decided to do the installation on both hosts again (seeing this as a test, will redo everything a last time once all has been setup and working)

Setup went fine but I am unable to find a target LUN - The target IQN is perfect, picks it up almost immediately, but when I search for a LUN it comes back with a
"No LUNs were found on 10.4.0.3" - I've also tried to change the LUN number during installation to 20 incase it was seeing previous install data but the same response.

I believe after this installation should be complete so hoping you can assist :)

HERE ARE iSCSI-CFG LOGS:

MASTER

| iSCSI-HA Version IHA_2.1.4_29881 |
| Sun Jul 16 09:28:08 SAST 2017 |

| iSCSI-HA Status: Running 2569 |
| Last Updated: Sun Jul 16 09:28:00 SAST 2017 |
| HOST ROLE: MASTER |
| DRBD ROLE: iscsi1=Primary |
| DRBD CONNECTION: iscsi1 in SyncSource state |
| ISCSI TARGET: Running [expected running] |
| VIRTUAL IP: 10.4.0.3 is local |
Control + C to exit


| DRBD Status |

| version: 8.4.5 (api:1/proto:86-101) |
| srcversion: 2A6B2FA4F0703B49CA9C727 |
| 1: cs:SyncSource ro:Primary/Secondary ds:UpToDate/Inconsistent C r
|
| ns:51041280 nr:0 dw:0 dr:51042192 al:0 bm:0 lo:0 pe:15 ua:0 ap:0 ep:1 wo:f oos:2835076920 |
| [>....................] sync'ed: 1.8% (2768628/2818472)M |
| finish: 25:16:37 speed: 31,132 (29,332) K/sec |


SLAVE:
| iSCSI-HA Version IHA_2.1.4_29881 |
| Sun Jul 16 09:26:24 SAST 2017 |

| iSCSI-HA Status: Running 2190 |
| Last Updated: Sun Jul 16 09:26:19 SAST 2017 |
| HOST ROLE: SLAVE |
| VIRTUAL IP: 10.4.0.3 is not local |
| ISCSI TARGET: Stopped [expected stopped] |
| DRBD ROLE: iscsi1=Secondary |
| DRBD CONNECTION: iscsi1 in SyncTarget state |
Control + C to exit


| DRBD Status |

| version: 8.4.5 (api:1/proto:86-101) |
| srcversion: 2A6B2FA4F0703B49CA9C727 |
| 1: cs:SyncTarget ro:Secondary/Primary ds:Inconsistent/UpToDate C r
|
| ns:0 nr:47940480 dw:47940480 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0 ep:1 wo:f oos:2838175800 |
| [>....................] sync'ed: 1.7% (2771656/2818472)M |
| finish: 25:49:53 speed: 30,500 (29,320) want: 81,720 K/sec |
Last Edit: 1 year 3 months ago by Mauritz.
The administrator has disabled public write access.

Different sized storage 1 year 3 months ago #1359

Got it working!

There was incorrect lun settings in the config file left by the previous installation. I removed that and all was perfect!
The administrator has disabled public write access.

Different sized storage 6 months 4 weeks ago #1587

Following up.
Thanks all above for input and sharing your issues as it helped me.
It turned out my /dev/sdb was locked up. Essentially it turned out the quickest way to go about fixing the issue was a full fresh install of 7.2. On running the HA-Lizard iSCSI install everything synced up.
Oddly though I had different read times on the different machines. Not sure why that happened but things are syncing nice.
Thanks again for sharing
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.137 seconds