Forum
Welcome, Guest
Username: Password: Remember me
This is the optional category header for the Suggestion Box.
  • Page:
  • 1

TOPIC:

service iscsi-ha failed 2 months 3 weeks ago #2129

  • Wellington Maesta da Silva
  • Wellington Maesta da Silva's Avatar Topic Author
  • Offline
  • Posts: 8
Hi Folks,

At the restart server, the service iscsi-ha is failed to the start.
I ran the command HA-CFG STATUS, and returned the error below:

ha-cfg status
| ha-lizard Version: 2.2.3 |
| Operating Mode: Mode [ 2 ] Managing All VMs in Pool |
| Host Role: master |
| slave |
| Pool UUID: |
| Host UUID: 0eabac2d-fde4-45bf-ae26-677efb516f5f |
| Master UUID: 0eabac2d-fde4-45bf-ae26-677efb516f5f |
| Daemon Status: ha-lizard is not running [ STOPPED ] |
| Watchdog Status: ha-lizard-watchdog is running [ OK ] |
| HA Enabled: |
Pool HA Status: UNKNOWN
ha-lizard-enabled is not set or set to an invalid value.
Enter <true> to enable or <false> to disable
true
Broadcast message from systemd-journald@xcp1 (Tue 2020-09-08 16:57:35 -03):

xapi-nbd[12427]: main: Failed to log in via xapi's Unix domain socket in 300.000000 seconds


Broadcast message from systemd-journald@xcp1 (Tue 2020-09-08 16:57:35 -03):

xapi-nbd[12427]: main: Caught unexpected exception: (Failure


Broadcast message from systemd-journald@xcp1 (Tue 2020-09-08 16:57:35 -03):

xapi-nbd[12427]: main: "Failed to log in via xapi's Unix domain socket in 300.000000 seconds")



Can anyone help me with this problem?

Wellington

Please Log in or Create an account to join the conversation.

service iscsi-ha failed 2 months 3 weeks ago #2130

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 653
All active configuration parameters are stored in the XAPI database. The error you are getting indicates that the parameter which stores the HA enabled flag is missing.

You can run the below command to verify this outside of the ha-cfg cli tool.
xe pool-param-get param-name=other-config param-key=XenCenter.CustomFields.ha-lizard-enabled uuid=$(xe pool-list --minimal)

The result of the above should be either "true" or "false". Can you post the result of the above.

Also, the topic states that iscsi-ha failed to start. There are primarily 2 requirements for this service to start. 1) properly configured firewall 2) XAPI must be completely loaded. We wait for a lock file (cookie) to appear before the service will start. If the cookie does not appear in 300 seconds after boot, iscsi-ha will fail to start. XAPI writes this file out once it has completed loading "/var/run/xapi_init_complete.cookie". Please also check on whether this file exists. If it does and iscsi-ha failed to start on boot, it could be that XAPI took a very long time to start. You can test this theory by trying "service iscsi-ha-watchdog start". If it succeeds, then chances were that there was some delay in XAPI starting on boot.

Please Log in or Create an account to join the conversation.

service iscsi-ha failed 2 months 3 weeks ago #2135

  • Wellington Maesta da Silva
  • Wellington Maesta da Silva's Avatar Topic Author
  • Offline
  • Posts: 8
Thanks Salvatore,

The result of this command (xe pool-param-get param-name=other-config param-key=XenCenter.CustomFields.ha-lizard-enabled uuid=$(xe pool-list --minimal)) is:

The server could not join the liveset because the HA daemon could not access the heartbeat disk.
The server could not join the liveset because the HA daemon could not access the heartbeat disk.

I checked the server interfaces 1 and 2, and both communicate (10.10.10.1 and 10.10.10.2), but the iscsi interface does not see any of them (10.10.10.3).

I checked the / var / run / folder and found these files:
ha-lizard-watchdog.pid
iscsi-ha-watchdog.pid
xapi.pid
xapi_startup.cookie

The iscsi-ha-watchdog service is already started, only the iscsi-ha service has not started.

Regards,

Wellington

Please Log in or Create an account to join the conversation.

service iscsi-ha failed 2 months 3 weeks ago #2137

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 653
It appears you may have enabled the native high availability (within XCP-ng or Xenerver), which will conflict with HA-Lizard. We detect this scenario and prevent HA-Lizard from starting. Try disabling the native HA functionality. That should get everything working again.

Please Log in or Create an account to join the conversation.

service iscsi-ha failed 2 months 3 weeks ago #2144

  • Wellington Maesta da Silva
  • Wellington Maesta da Silva's Avatar Topic Author
  • Offline
  • Posts: 8
Thanks for the help, it worked! I disabled native HA, and everything returned to working normally.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1