Forum
Welcome, Guest
Username: Password: Remember me
This is the optional category header for the Suggestion Box.

TOPIC: Unable to install iSCSI Target Framework

Unable to install iSCSI Target Framework 1 year 2 months ago #1344

We have a similar problem as #1309

we run on 2 x DL380G7 and installed Xenserver 7.2

after running
yum install scsi-target-utils --enablerepo=ha-lizard-e
we get:
Loaded plugins: fastestmirror
Bad id for repo: ha-lizard-epel , byte = 14
Loading mirror speeds from cached hostfile
* ha-lizard-base: mirror.centos.org
No package scsi-target-utils available.
Error: Nothing to do

So we changed /etc/yum.repos.d, just a described in #1309
Then we get:
yum install scsi-target-utils --enablerepo=ha-lizard-epel,ha-lizard-base
Loaded plugins: fastestmirror
Bad id for repo: ha-lizard-epel , byte = 14
Loading mirror speeds from cached hostfile
* ha-lizard-base: mirrors.supportex.net
Resolving Dependencies
--> Running transaction check
---> Package scsi-target-utils.x86_64 0:1.0.14-2.el5 will be installed
--> Processing Dependency: libibverbs.so.1(IBVERBS_1.1)(64bit) for package: scsi-target-utils-1.0.14-2.el5.x86_64
--> Processing Dependency: librdmacm.so.1(RDMACM_1.0)(64bit) for package: scsi-target-utils-1.0.14-2.el5.x86_64
--> Processing Dependency: perl(Config::General) for package: scsi-target-utils-1.0.14-2.el5.x86_64
--> Processing Dependency: libibverbs.so.1()(64bit) for package: scsi-target-utils-1.0.14-2.el5.x86_64
--> Processing Dependency: librdmacm.so.1()(64bit) for package: scsi-target-utils-1.0.14-2.el5.x86_64
--> Running transaction check
---> Package libibverbs.x86_64 0:1.2.1-1.el7 will be installed
--> Processing Dependency: rdma for package: libibverbs-1.2.1-1.el7.x86_64
---> Package librdmacm.x86_64 0:1.1.0-2.el7 will be installed
---> Package perl-Config-General.noarch 0:2.40-1.el5 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-Config-General-2.40-1.el5.noarch
--> Running transaction check
---> Package perl-Config-General.noarch 0:2.40-1.el5 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-Config-General-2.40-1.el5.noarch
---> Package rdma.noarch 0:7.3_4.7_rc2-5.el7 will be installed
--> Finished Dependency Resolution
Error: Package: perl-Config-General-2.40-1.el5.noarch (C5.10-base)
Requires: perl(:MODULE_COMPAT_5.8.8)
Available: 4:perl-5.8.8-41.el5.x86_64 (C5.10-base)
perl(:MODULE_COMPAT_5.8.8)
Installed: 4:perl-5.16.3-286.el7.x86_64 (@install/$releasever)
~perl(:MODULE_COMPAT_5.16.0)
~perl(:MODULE_COMPAT_5.16.1)
~perl(:MODULE_COMPAT_5.16.2)
~perl(:MODULE_COMPAT_5.16.3)
Available: 4:perl-5.16.3-291.el7.x86_64 (ha-lizard-base)
~perl(:MODULE_COMPAT_5.16.3)
~perl(:MODULE_COMPAT_5.16.2)
~perl(:MODULE_COMPAT_5.16.1)
~perl(:MODULE_COMPAT_5.16.0)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


What to do?
The administrator has disabled public write access.

Unable to install iSCSI Target Framework 1 year 2 months ago #1349

Thanks for posting. We have not seen this yet, but will give it a try to see if we can reproduce it.
The administrator has disabled public write access.

Unable to install iSCSI Target Framework 8 months 5 days ago #1527

Same issue for us. Something new about it?
We are running XenServer 7.2
Thanks.
The administrator has disabled public write access.

Unable to install iSCSI Target Framework 8 months 2 days ago #1530

I just tested a complete installation on a pair of 7.2 hosts and did not experience the issue. Perhaps there is a DNS issue or some other problem reaching the centos epel repo from your installation site?

I used:
- clean install of 7.2 on 2 hosts
- this installation script: halizard.com/ha-lizard-software/ha-lizard-nosan-installer-xen-7
The administrator has disabled public write access.
Time to create page: 0.082 seconds