Forum
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

iSCSI issues 2 weeks 6 days ago #2219

After rebooting my servers something isn't starting up correctly. I have 2 iSCSI drives set up that worked fine before I had to shut the servers down for a power outage. Now the slave comes up as iscsi1 in StandAlone state and iscsi2 in Unconfigured state. The master shows them both in WFConnection state.

I stopped things manually (iscsi-ha-watchdog, iscsi-ha, tgtd, drbd) and tried to start manually. drbd starts up ok but tgtd does not and I don't understand the errors:
● tgtd.service - tgtd iSCSI target daemon
Loaded: loaded (/usr/lib/systemd/system/tgtd.service; disabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/tgtd.service.d
└─local.conf
Active: failed (Result: exit-code) since Fri 2020-10-09 07:51:45 EDT; 48s ago
Process: 1396 ExecStop=/usr/sbin/tgtadm --op delete --mode system (code=exited, status=0/SUCCESS)
Process: 1390 ExecStop=/usr/sbin/tgt-admin --update ALL -c /dev/null (code=exited, status=0/SUCCESS)
Process: 1387 ExecStop=/usr/sbin/tgtadm --op update --mode sys --name State -v offline (code=exited, status=0/SUCCESS)
Process: 1348 ExecStartPost=/usr/sbin/tgt-admin -e -c $TGTD_CONFIG (code=exited, status=22)
Process: 1345 ExecStartPost=/usr/sbin/tgtadm --op update --mode sys --name State -v offline (code=exited, status=0/SUCCESS)
Process: 1321 ExecStartPost=/bin/sleep 5 (code=exited, status=0/SUCCESS)
Process: 1319 ExecStart=/usr/sbin/tgtd -f $TGTD_OPTS (code=exited, status=0/SUCCESS)
Main PID: 1319 (code=exited, status=0/SUCCESS)

At this stage, the master then shows that both iscsi drives are in SyncSource state. With "service iscsi-ha start -w" I'm able to get it running again. So now it looks like everything is syncing but tgtd is not running.

Any suggestions on cleaning this up?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1