Forum
Welcome, Guest
Username: Password: Remember me

TOPIC: e-mail alert: xe_wrapper: COMMAND: xe host-list hostname=IT1XENSLAVE1 --minimal

e-mail alert: xe_wrapper: COMMAND: xe host-list hostname=IT1XENSLAVE1 --minimal 3 months 1 week ago #1842

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 593
I accidentally deleted your last post, so I am pasting it below for reference. In answer to your question, it is not necessary to promote the slave to master while in maintenance mode. The only reason to do that would be if you needed xenxcenter access to the slave. If you can do without xencenter while you work on the master, then it would be simpler just to remain in manual mode while you work on the master.

.The Performance data from XenServer are not anymore visible in XenCenter before the incident date


Theerfore I do not have any chance to see on the VMs any trigger for this problem.

However, I do run on the slave three smaller VMs and one of them, a CentOS based e-mail gateway have report yesterday also an unexpected service shutdown. As we run DRBD in single primary master mode this is directing me again to the storage layer of the primery master, were the problem started on Monday morning . The RAID Hardware and the controller have not reported any non recoverable error, but I expect this very soon.

I will now search on this level of the hardware and move my VMs in manual mode to the slave.

Should I promote the current slave also as the new XenServer Poolmaster?

Please Log in or Create an account to join the conversation.

e-mail alert: xe_wrapper: COMMAND: xe host-list hostname=IT1XENSLAVE1 --minimal 3 months 1 week ago #1843

As we soon go offline with our "questionable" master, I will update also BIOS and iRMC Software to manage the Server hardware. They are not too old (3 years) so I am asking myself to upgrade the HA-Lizard and ISCSI software stack to the most recent versions.

Should we or should we stay on 2.1.4/.2.1.4?

I have also followed discussion about upgrading to XCP 7.X / 7.6. I have understood that this is also possible, but in older documentation I have found a note from you, telling me to avoid any major upgrade of an existing installation of HA-Lizard/XenServer.

Would you recommend to stay on XenServer 6.5SP1 or to going to XCP7.6?
BR Andreas

By the way: Thank you for this wonderful piece of software!

Please Log in or Create an account to join the conversation.

e-mail alert: xe_wrapper: COMMAND: xe host-list hostname=IT1XENSLAVE1 --minimal 3 months 1 week ago #1844

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 593
In older versions of our SW, the challenge was preserving critical config data during a major version upgrade, which erases Drbd, lvm and iscsi target configuration data along with required packages. We have addressed this in our latest release which can store all of the required config data in the xapi db, hence allowing the data to survive a major upgrade.

The process is documented in the link below.

Regarding whether to move to xcp 7.6, I really can't say. I see no downside in migrating. You'll need to weigh the benefits of that.

halizard.com/forum/search?query=nosan_de...1/2019&childforums=1

Please Log in or Create an account to join the conversation.

Last edit: by Salvatore Costantino. Reason: typos

e-mail alert: xe_wrapper: COMMAND: xe host-list hostname=IT1XENSLAVE1 --minimal 3 months 1 week ago #1845

During my maintenance operation I have tried to update HA-Lizard and iSCSI-HA to the most recent versions using the rpm package.

This is not successful on XenServer 6.5 due to missing dependencies:
error: Failed dependencies:
        rpmlib(FileDigests) <= 4.6.0-1 is needed by ha-lizard-2.2.1-1.noarch
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by ha-lizard-2.2.1-1.noarch

I will check if this is possible with the *.tgz versions

Please Log in or Create an account to join the conversation.

e-mail alert: xe_wrapper: COMMAND: xe host-list hostname=IT1XENSLAVE1 --minimal 3 months 1 week ago #1846

  • Salvatore Costantino
  • Salvatore Costantino's Avatar
  • Offline
  • Posts: 593
the tarball should install fine since it has no dependency check. The dependencies are TGT and DRBD which you have already, just older versions which are fine.

Please Log in or Create an account to join the conversation.

e-mail alert: xe_wrapper: COMMAND: xe host-list hostname=IT1XENSLAVE1 --minimal 3 months 1 week ago #1848

after upgrading HA-Lizard and iSCSI-HA on my XenServer 6.5 it hangs while rebooting the host while the firewall script entry on line 65 is not found. After the time out of the script the host is starting.

What should I modify?

I could not ping the floating IP 10.10.10.3 but both others from this host. (I am still on manual-mode).
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by ajmind.