Forum
Welcome, Guest
Username: Password: Remember me

TOPIC: "The Storage Repository is not available", XS upg

"The Storage Repository is not available", XS upg 7 months 2 days ago #1486

So, I have a cluster of 2 servers that are getting ready to be placed into production. They were running XS 7.2, ha-lizard 2.1.4, and iscsi-ha 2.1.5.
Before putting them into service, I upgraded the hypervisors to the latest release, XS 7.3. Even though I used the "upgrade" option, this had the effect of completely removing all of my ha-lizard files and configurations (although, interestingly enough, XenCenter still showed the iscsi SR as "connected", even though the target IP was gone).

I removed the SR from the pool, and reinstalled ha-lizard, iscsi-ha, and drbd, per the documentation. iscsi-cfg status shows everything is working properly.
However.... when I try to re-create my iscsi SR, it finds the target IQN, and detects the LUN. When it scans for LVMs, it prompts me to format the disk. I say yes, and after running for a second, it returns

"The storage repository is not available. Check your settings and try again."

No additional errors, nothing in the logs to point at what may have went wrong.
I disabled the firewall, hoping that was the problem. Negative. I restarted all the related services, nothing. I'm at a loss. Help? :)
The administrator has disabled public write access.

"The Storage Repository is not available", XS upg 7 months 2 days ago #1487

So, nevermind, I got it.
I ended up having to blow away the pool master's storage, let drbd begin replication back to it from the slave, then put iscsi-ha into manual mode and set the slave as the iscsi master - then I was able to create my SR. When the replication reaches an UpToDate/UpToDate status, I'll re-promote the pool master to iscsi-ha master and disable manual mode.
The administrator has disabled public write access.
Time to create page: 0.073 seconds